jamesauth - Password reset link doesn’t work – Incident details
All systems operational
Password reset link doesn’t work
Resolved
Partial outage
Started 22 days agoLasted 5 days
Affected
Authentication
Partial outage from 2:21 PM to 3:18 PM
Internal Authentication
Partial outage from 2:21 PM to 3:18 PM
Updates
Resolved
Resolved
This incident has been resolved. In future, please contact us to reset your password.
Investigating
Investigating
When clicking the reset password link in the password reset email, it does not prompt you to reset your password. We are currently investigating this incident further.